Saturday, February 28, 2015

Difference between configuring clock rate and bandwidth commands - Clock Rate Vs Bandwidth


This article and the video below will clarify the confusion around using the clock rate command and bandwidth command.

Clock Rate is the actual speed of data transfer- physical speed of an interface, It is used usually by the service provider on the serial interface when the customer needs to connect two sites together.

Looking at the diagram above, to adjust the line speed of the link between site1 and site2 to 64kbps use the following command.
R(config)#int s0/0/0
R(Config-if)#clock rate 64000

Bandwidth is used to set the bandwidth of the interface used by QoS and routing protocols to select the best path. It doesn't affect the actual interface speed or line speed.
R(config)#int s0/0/0
R(Config-if)#bandwidth 64

To know how routing protocols such as ospf and eigrp use bandwidth, read the following articles
http://netsyshorizon.blogspot.com/2015/02/by-default-ospf-cost-calculationis.html
http://netsyshorizon.blogspot.com/2015/02/eigrp-metric-calculation_25.html



For more details and explanation , watch this video on youtube
YouTube - Clock rate Vs Bandwidth
http://youtu.be/rntsm5bHagI

To download the video from mediafire
Mediafire - Clock rate Vs Bandwidth

To get automatic updates, join a facebook group (netsyshorizon)
https://www.facebook.com/groups/954180217947066/

Thursday, February 26, 2015

Configure PPPoE Client Configuration on cisco routers - Cisco 887VA router as PPPoE client over DSL




In this article, I will explain configuring the cisco 887va router as PPPoE client over ADSL.
 There are two options to connect a cisco router over DSL:

PPPoE on Ethernet interfaces: PPPoE is configured on a cisco router with two Fast Ethernet interfaces. One Ethernet interface is connected to the service provider, and the other is connected to the local area network.
PPPoE on ATM interfaces: PPPoE is configured on a Cisco router with oneFast Ethernet interface connected to the local area network, and one ATM interface (RJ-11) connected to the service provider.

Before starting the configuration we should know there is a logical interface on the router called dialer interface which contains configuration information (such as encapsulation protocol, dialer pool number, username and password) to connect to the ISP.
A dialer interface must be used for cloning virtual access. Multiple PPPoA client sessions can be configured on an ATM interface, but each session must use a separate dialer interface and a separate dialer pool.

Configuration steps

1.       Configure the LAN interface: First of all, assign ip address for local network, for example 10.100.1.0/24, Cisco 887VA router has four layer 2 switch ports belong to vlan 1 by default. So, assign an ip address to the interface vlan 1 for your local network.
R(config)#int vlan 1
R(config-if)#ip address 192.168.50.1 255.255.255.0
R(config-if)#no sh           

2.       Configure the ATM interface: Creates an ATM PVC for each end node (up to ten) with which the router communicates. Enters ATM virtual circuit configuration mode. When a PVC is defined, AAL5SNAP encapsulation is defined by default.
Router(config)# interface atm 0
Router(config-if)# pvc 8/35
Specifies the encapsulation type for the PVC and points back to the dialer interface.
Router(config-if-atm-vc)# encapsulation aal5mux ppp dialer
Specifies the ATM interface as a member of a dialer profile dialing pool. The pool number must be in the range of 1–255.
Router(config-if-atm-vc)# dialer pool-member 1

3.       Configure the dialer interface: The Dialer interface should be 1492 as PPPoE adds an 8 byte encapsulation header.  the maximum/default Ethernet MTU size is 1500 bytes.Specifies that the IP address for the dialer interface is obtained through PPP/IPCP (IP Control Protocol) address negotiation. The Fast Ethernet interface carries the data packet through the LAN and off-loads it to the PPP connection on the ATM interface. The ATM traffic is encapsulated and sent over the xDSL interface. The dialer interface is used to connect to the ISP.
 Router(config)# interface dialer 0
Router(config-if)# ip address negotiated
Sets the size of the IP maximum transmission unit (MTU). The default minimum is 128 bytes. The maximum for ATM is 4470 bytes.
Router(config-if)# ip mtu 1492
Sets the encapsulation type to PPP for the data packets being transmitted and received.
Router(config-if)# encapsulation ppp
Specifies the dialer pool to use to connect to a specific destination subnetwork.
Router(config-if)# dialer pool 1

4.       Configure Default route
Router(config)# ip route 10.10.25.2 0.255.255.255 dialer 0

5.       Configure NAT: you need to allow the local network to reach the internet, so you should configure Nat on your router by specifying the inside interface (vlan 1) and outside interface(dialer 1), and specifying which range of ip addresses can access the internet using the access-list as shown below.
R(Config)#access-list 1 permit 192.168.50.0 255.255.255.0
Router(config)# ip nat inside source list 1
interface dialer 1 overload
Router(config)# interface vlan 1
Router(config-if)# ip nat inside
Router(config)# interface dialer 0
Router(config-if)# ip nat outside

When we configure ATM and dialer interface as shown above, we use pvc provided by DSL provider on the atm interface, and use username and passwords provided by the DSL provider on the dialer interface.

To do so, the video link below is created on real-time environment
To download the configuration file, and the scenario file, click on the following link
To get automatic updates, join a facebook group (netsyshorizon)
https://www.facebook.com/groups/954180217947066/

Related Links:
Difference between network and internetwork and what are types of networks
https://youtu.be/pGIkjYf9wC8
Unicast Multicast Broadcast Anycast Network Traffic Types / Transmission Types
https://youtu.be/xr1u3LUwcek
Assign ip address to cisco layer 2 switch / Assign ip address to vlan
https://youtu.be/Q9SUVmyJr80
Telnet Vs SSH - Difference between Telnet and SSH Configuration
https://youtu.be/15pfENww-dk
Configure DHCP on Cisco router - Cisco router as a DHCP Server
https://youtu.be/YTCgVn9X4ac
SSH from cisco router and switch to another
https://youtu.be/_I-0Vgc8E9s
OSPF Cost Calculation and Configuring Bandwidth/ip ospf cost/reference bandwidth
https://youtu.be/zgqaVkQe5Sw
EIGRP Composite Metric Calculation and Configuring different delay values and Bandwidth values

https://youtu.be/GsnV4Bc3On8
Configure / Assign IP address to Cisco Layer 3 Switch
https://youtu.be/s9DMZCq27Ys
Configuring cisco extended ACL / extended named access control list tutorial using packet tracer
https://youtu.be/Tj6H8pg06f0
Configure Cisco  Extended ACL/ Extended Numbered Access Control List ACL Using Packet Tracer
https://youtu.be/j0CDNAa2Wqg
Port Forwarding and Static Nat on Cisco Routers - Access your private network from the internet
https://youtu.be/8WVWoW86Uhw
Configure Cisco Named Standard Access Control List ACL on Cisco routers
https://youtu.be/u2zmuRZazFw
How Access List works - Numbered Standard Access List configuring
https://youtu.be/rLci6mFg2BA
Cisco router WAN Redundancy/WAN Failover and Change Routing dynamically Using IP SLA - Route Tracking
https://youtu.be/x3xZhbrX7Ww
Cisco Named Access Control Lists Editing (add and delete individual lines + re-sequence)
https://youtu.be/RToV6h2rGeM
Connecting  GNS3 to VMware

https://youtu.be/WuLf3ESAx94
How to download and install GNS3 1.2 + adding IOS image to GNS3

https://youtu.be/CXVNpERIPo4
Mikrotik router PPPoE client configuration - Mikrotik PPPoE client Setup
https://youtu.be/aUGL20rjbVA
Add IOS images to GNS3
https://youtu.be/GjxODWeuC5Y
Connect your PC to GNS3 - connecting GNS3 to local machine
https://youtu.be/c_b_-rGWnJc
Configuration register value - changing the configuration register
https://youtu.be/YVAKerOmJpk
Backup and Restore Cisco Configuration file -  Cisco backup Config
https://youtu.be/YMX1EMPjBC0
Capture telnet password using wireshark - Sniffing telnet password using wireshark
https://youtu.be/xShwyUq-uHk
Clock Rate vs Bandwidth - Configuring clock rate and bandwidth
https://youtu.be/rntsm5bHagI
Configure Default routes on cisco routers
https://youtu.be/E5-kpZt8LU4
Configure cisco router hostname and ip address
https://youtu.be/1OYMlMzQ1dE
Cisco Router Password Recovery
https://youtu.be/6shdtrAx9l0
Static Routing Configuration Using Packet Tracer
https://youtu.be/v05Jm4h-Zms


Keywords:
cisco pppoe configuration; cisco pppoe configuration example; cisco pppoe with static nat; cisco pppoe configuration guide; cisco pppoe ethernet configuration; cisco pppoe config; cisco pppoe config example; cisco pppoe config 887; cisco pppoe config 800 series; cisco pppoe tutorial; cisco pppoe troubleshoot; cisco pppoe username password; cisco pppoe interface; cisco pppoe over ethernet; cisco pppoe over atm; cisco ppp over ethernet example; cisco ppp over ethernet configuration; pppoe over ethernet configuration cisco; cisco pppoe over adsl configuration; cisco pppoe over atm configuration; cisco pppoe over authentication; cisco pppoe server; cisco pppoe router; cisco pppoe static ip address; cisco pppoe access lists; cisco pppoe adsl config; cisco pppoe adsl configuration; cisco pppoe server configuration example in the other tutorials; cisco pppoe dialer; cisco ppoe dialer configuration; cisco pppoe dialer interface; cisco pppoe dialer mtu; cisco adsl dialer mtu; cisco ip mtu 1492; cisco router mtu setting; change mtu on cisco router; adsl pppoe mtu size; cisco pppoe client configuration example; cisco pppoe client example; cisco pppoe client tutorial lab; how to configure pppoe client cisco routers; cisco pppoe-client dial-pool-number; cisco router pppoe client configuration; pppoe client setup configuration; how to setup pppoe on cisco routers; pppoe config cisco; cisco pppoe client nat; cisco pppoe nat configuration example; pppoe client configuration; pppoe client cisco ios; pppoe client cisco router; pppoe client configuration on cisco router; cisco adsl pppoe configuration; cisco troubleshoot pppoe; how to setup pppoe on cisco router; cisco router pppoe configuration ethernet interface; cisco router pppoe client configuration example. 

Tuesday, February 24, 2015

OSPF Cost Calculation and Configuring Bandwidth/ ip ospf cost/ reference bandwidth


By default the OSPF cost calculation is based on a reference bandwidth of 100Mbps. So, the ospf cost calculation formula as the following.

Cost(Metric) = Reference Bandwidth(kbps) / Configured Bandwidth(kbps).
OSPF Metric = 100Mbps / Configured BW
OSPF Metric = 100000kbps / Configured BW

ospf cost calculation example


You  should know the configured bandwidth for any interface using show interface command, as you see below.

Site1#sh int f0/0
FastEthernet0/0 is up, line protocol is up (connected)
  Hardware is Lance, address is 00e0.8f3b.5601 (bia 00e0.8f3b.5601)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
Site2#sh int s0/0/0
Serial0/0/0 is up, line protocol is up (connected)
  Hardware is HD64570
  Internet address is 10.10.11.1/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,

Based on the above show commands,
  • The default configured bandwidth for the fast Ethernet link is 100000kbps, so the metric(cost) is 100000/100000=1
  • The default configured bandwidth for the serial link is 100000kbps, so the metric(cost) is 100000/100000=1 


Looking at the above diagram, we should be able to know the metric of the path from site 1 router to site 3 network.
Metric = Cost of the serial link between site1 router and site2 router+ cost of the fast Ethernet link of site2 router
Cost(Metric) = 100000/1544+100000/100000
Cost(Metric) = 64+1
Cost(Metric) = 65

You can change the default Configured bandwidth for any interface using this command
Site1(config)#int f0/0
Site1(config-if)#bandwidth ?
  <1-10000000>  Bandwidth in kilobits


Important Notes:
  1. If you calculate the path metric from site 1 to site 2 network 10.10.12.0/24, you have to use the bandwidth value of the outbound interfaces, means the values of the s/0/0/0 of site 1 router , and , and f0/1 of site 2 router.
  2. If you calculate the path metric from site 2 to site 1 network 10.10.10.0/24, you have to use the bandwidth values of the outbound interfaces, means the values of the s0/0/0 of site 2 router, and fa0/0 of site 1 router.
So, the cost is based on the bandwidth value only, changing the bandwidth value will affect the cost, for example, if you change the bandwidth values as you see in the picture below, 




Now,

Cost(Metric) From site1 router to reach site2 network 10.10.12.0/24

Metric=10^8bps/BW in bps
Metric=100000kbps/Bw in kbps+100000/BW in kbps
Metric=100000kbps/800+100000/1200=125+83
Metric=208

Cost(Metric) From site2 router to reach site2 network 10.10.10.0/24

Metric=10^8bps/BW in bps
Metric=100000kbps/Bw in kbps+100000/BW in kbps
Metric=100000/700+100000/900=142+111
Metric=253

Site1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.10.10.0/24 is directly connected, FastEthernet0/0
C       10.10.11.0/30 is directly connected, Serial0/0/0
O       10.10.12.0/24 [110/208] via 10.10.11.2, 02:15:25, Serial0/0/0

Site2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.0/24 [110/253] via 10.10.11.1, 00:07:18, Serial0/0/0
C       10.10.11.0/30 is directly connected, Serial0/0/0
C       10.10.12.0/24 is directly connected, FastEthernet0/1

The other way to change the cost value, using ip ospf cost command, The value set by the ip ospf cost command overrides the cost resulting from the calculation matter 10^8/Bw in bps.

For example, if you want to change the cost value  of the interface f0/0 of site1 router to 20
Site1(config)#int f0/0
Site1(config-if)#ip ospf cost 20

So, the cost of f0/0 was 100000/9000=111, but after using the above command will be 20, this mean that Cost(Metric) From site2 router to reach site2 network 10.10.10.0/24

Metric=10^8bps/BW in bps
Metric=100000kbps/Bw in kbps+100000/BW in kbps
Metric=100000/700+20=142+20
Metric=162

Site2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       10.10.10.0/24 [110/162] via 10.10.11.1, 00:06:00, Serial0/0/0
C       10.10.11.0/30 is directly connected, Serial0/0/0
C       10.10.12.0/24 is directly connected, FastEthernet0/1

Also, you can change the reference bandwidth, which will affect the cost by using the 
 auto-cost reference-bandwidth mbps.

Also, you can cha If you have high bandwidth links, you should use a larger number of reference bandwidth to differentiate the cost of these links. It's important to know that the value set by ip ospf cost command will override the cost resulting from the auto-cost command.
Site1(config)#router ospf 10
R1(config-router)#auto-cost reference-bandwidth 1000

This simple and short video shows all the above (lab)


To get the packet tracer file. Just click on the following link

To get automatic updates, join a facebook group (netsyshorizon)
https://www.facebook.com/groups/954180217947066/

Related Links:
Assign ip address to cisco layer 2 switch / Assign ip address to vlan
https://youtu.be/Q9SUVmyJr80
Telnet Vs SSH - Difference betweenTelnet and SSH Configuration
https://youtu.be/15pfENww-dk
Configure DHCP on Cisco router - Cisco router as a DHCP Server
https://youtu.be/YTCgVn9X4ac
SSH from cisco router and switch to another
https://youtu.be/_I-0Vgc8E9s
OSPF Cost Calculation and Configuring Bandwidth/ip ospf cost/reference bandwidth
https://youtu.be/zgqaVkQe5Sw
EIGRP Composite Metric Calculation and Configuring different delay values and Bandwidth values
https://youtu.be/GsnV4Bc3On8
Configure / Assign IP address to Cisco Layer 3 Switch
https://youtu.be/s9DMZCq27Ys
Configuring cisco extended acl / extended named access control list tutorial using packet tracer
https://youtu.be/Tj6H8pg06f0
Configure Cisco  Extended ACL/ Extended Numbered Access Control List ACL Using Packet Tracer
https://youtu.be/j0CDNAa2Wqg
Port Forwarding and Static Nat on Cisco Routers - Access your private network from the internet
https://youtu.be/8WVWoW86Uhw
Configure Cisco Named Standard Access Control List ACL on Cisco routers
https://youtu.be/u2zmuRZazFw
How Access List works - Numbered Standard Access List configuring
https://youtu.be/rLci6mFg2BA
Cisco router WAN Redundancy/WAN Failover and Change Routing dynamicaly Using IP SLA - Route Tracking
https://youtu.be/x3xZhbrX7Ww
Cisco Named Access Control Lists Editing (add and delete individual lines+resequence)
https://youtu.be/RToV6h2rGeM
Connecting  GNS3 to Vmware

https://youtu.be/WuLf3ESAx94
How to download and install GNS3 1.2 + adding IOS image to GNS3

https://youtu.be/CXVNpERIPo4
Mikrotik router PPPoE client configuration - Mikrotik PPPoE client Setup
https://youtu.be/aUGL20rjbVA
Add IOS images to GNS3
https://youtu.be/GjxODWeuC5Y
Connect your PC to GNS3 - connecting GNS3 to local machine
https://youtu.be/c_b_-rGWnJc
Configuration register value - changing the configuration register
https://youtu.be/YVAKerOmJpk
Backup and Restore Cisco Configuration file -  Cisco backup Config
https://youtu.be/YMX1EMPjBC0
Capture telnet password using wireshark - Sniffing telnet password using wireshark
https://youtu.be/xShwyUq-uHk
Clock Rate vs Bandwidth - Configuring clock rate and bandwidth
https://youtu.be/rntsm5bHagI
Configure Default routes on cisco routers
https://youtu.be/E5-kpZt8LU4
Configure cisco router hostname and ip address
https://youtu.be/1OYMlMzQ1dE
Cisco Router Password Recovery
https://youtu.be/6shdtrAx9l0
Static Routing Configuration Using Packet Tracer
https://youtu.be/v05Jm4h-Zms

Keywords:
configuring layer 3 interfaces
ospf cost calculation cisco example
how to configure ospf cost
how to calculate ospf cost
ospf metric calculation
ospf and cost calculation
ospf uses bandwidth to calculate the cost
calculating ospf cost
ospf metric value cost and ospf default cost
ospf path cost
ospf link cost
ospf equal cost paths
ospf reference bandwidth command
auto-cost reference-bandwidth command
ip ospf cost command
ospf area
ospf metric troubleshooting
ospf metric sample
ospf metric tutorial ccna ccnp
how to configure ospf cost
configuring ospf cost
configuring ospf interface cost
free ccna and ccnp material and videos ospf
ospf calculation formula
learning ospf cost
ip ospf cost example
ospf cost configuration
ospf configuration guide
ospf metric calculation example

Monday, February 23, 2015

Configure Default routes on cisco routers


Default routes are static routes and are also referred to as the Gateway of Last Resort. For more information about Static routing, read this simple article http://netsyshorizon.blogspot.com/2015/02/ip-static-routing-configuration-example-tutorial.html .  Configuring default routes is used to direct packets destined to networks not found in the routing table. It will direct these packets to another router that can reach to the destination or has the route to the destination.

Default Route Commands and Stub Networks
Looking at the above diagram, site1 router cannot reach the networks 10.10.12.0/24, 10.10.13.0/24, and 10.10.14.0/24 because they are not directly connected to it and there are no routes to reach them. So, you should configure site1 router to forward all packets destined to networks 10.10.12.0/24, 10.10.13.0/24, and 10.10.14.0/24 to the next hop router (site2)  using static route or default route.
Default route is usually used on the routers in stub network. Stub network: a network having only one connection to reach all the destinations.

Two methods to configure a default route

  • Send all packets destined for networks not in my routing table to next hop router ip address 10.10.11.2
    Router(config)#ip route 0.0.0.0 0.0.0.0 10.10.11.2
  • Send all packets destined for networks not in my routing table out my Serial 0/0/0 interface
     Router(config)#ip route 0.0.0.0 0.0.0.0 s0/0/0
To view the routing table which router direct the packet based on, the following route table shows that we are  using the next hop address not the exit interface. 
Site1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.10.11.2 to network 0.0.0.0
     10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       10.10.10.0/24 is directly connected, FastEthernet0/0
C       10.10.11.0/30 is directly connected, Serial0/0/0

S*   0.0.0.0/0 [1/0] via 10.10.11.2

To watch the simple and short video on youtube


To download the simple and short video from mediafire

To download packet tracer file
 
Mediafire - Default route packet tracer file

To get automatic updates, join a facebook group (netsyshorizon)
https://www.facebook.com/groups/954180217947066/

Related Links:
OSPF Cost Calculation and Configuring Bandwidth/ip ospf cost/reference bandwidth
https://youtu.be/zgqaVkQe5Sw
EIGRP Composite Metric Calculation and Configuring different delay values and Bandwidth values
https://youtu.be/GsnV4Bc3On8
Cisco router WAN Redundancy/WAN Failover and Change Routing dynamically Using IP SLA - Route Tracking
https://youtu.be/x3xZhbrX7Ww
Clock Rate vs Bandwidth - Configuring clock rate and bandwidth
https://youtu.be/rntsm5bHagI
Configure Default routes on cisco routers
https://youtu.be/E5-kpZt8LU4
Static Routing Configuration Using Packet Tracer
https://youtu.be/v05Jm4h-Zms

Keywords:

default route configuration  ; default route cisco ; default route lab ; default route tutorial ; default route ccna ; default route static routing ; default router ; cisco default route configuration ; configuring default route ; default route packet tracer ; default route ; static and default route ; cisco default route ; default static route ; what is default route ; default route definition ; default route explained ; default route explanation ; default route tutorial ; ccna ; ccnp ; ccie ; default route cisco ios ; default route cisco 0.0.0.0; default route command ; default route command cisco packet tracer ; default route config ; default route configuration on a cisco router ; default routing configuration cisco router pdf ; default routing example ; default routing metrics ; default route cisco 3750 ; default route admin distance ; default route exit interface ; default route next hop ; default router ; default route subnet mask ; default route gateway of last resort ; default route gns3 ; default route cisco router ; default route vs static route ; default route vs default gateway ; default route vs gateway of last resort; default route vs default network ; default route vs default network ; default route vs default network ; default route networking ; default route not working cisco ; default route not working cisco ; default route not working cisco ; cisco default route command ; cisco default route ipv6 ; cisco default route metric ; cisco default route interface ; cisco default route configuration ; cisco default route example ; cisco default route example ; cisco default route dhcp ; cisco default route administrative distance ; cisco default route not working ; cisco default route without gateway ; cisco default routing ; cisco default routing ; default routing metrics ; default routing and remote access class ; default routing table ; default routing configuration cisco router ; default routing pdf ; default routing configuration cisco router pdf ; default routing configuration example ; default route configuration command ; example default route ; example of default route cisco ; default route lab.

Sunday, February 15, 2015

Cisco Static Routing Configuration and lab


First of all, we should know that IP Routing is moving packets from network to another using routers.
There are two types of Routing: Static and dynamic, in this article will explain the static routing. In static routing, the administrator is responsible for inserting new routes to reach the remote networks or updating all changes (routes changes) by hand into all routers.
 As shown in the figure below, If we have 3 networks (10.10.10.0/24, 10.10.11.0/24, and 10.10.12.0/24). PC0 can access all machines in its network, but cannot access PC3 (network 10.10.12.0/24) because it belongs to different network. 



So, We should forward the packets coming from  PC0(network 10.10.10.0/24) going to PC3 (network 10.10.10.0/24) to the gateway(Site1 Router) which can forward  the packet to the other network(10.10.12.0/24).
Site1 Router can access the Directly Connected networks:10.10.10.0/24 and 10.10.11.0/30 but can not access network 10.10.12.0/24.So, we should configure the Site1 router to forward the packet that going to 10.10.12.0/24 to the Site2 Router using the following command
Site1(config)#ip route 10.10.12.0 255.255.255.0 10.10.11.2
Also, Site2 router should forward the packets going to network 10.10.10.0/24 to  Site1 router which can access that network. 
Site2(config)#ip route 10.10.10.0 255.255.255.0 10.10.11.1

These routes are stored in a routing table that the router use to make a decision of how to forward the packets. To view the routing table that Site1 router forward the packets based on its entries
Site1#sh ip route
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.10.10.0/24 is directly connected, FastEthernet0/0
C       10.10.11.0/30 is directly connected, Serial0/0/0
S       10.10.12.0/24 [1/0] via 10.10.11.2

Based on the routing table above, it's clear that if one of the devices belongs to network 10.10.10.0/24 wants to send a packet to network 10.10.12.0/24, it will send this packet to its default gateway which is here in this example Site1 router. When Site1 router receive the packet, it will look at the routing table entries to see how to get the destination network. the routing table of Site1 router include the bold route above that Site1 router will use to get the network 10.10.12.0/24 by forwarding the packet to the next hop address 10.10.11.2. The ip address 10.10.11.2 belongs to Site2 router that is directly connected to the network 10.10.12.0/24, so Site2 router can send the packet to the destination network devices 10.10.12.0/24. 

Note: Default route is considered static route , to know more about default routes and when we use them and how to configure them, visit this post http://netsyshorizon.blogspot.com/2015/02/configure-default-routes-on-cisco.html




To get more details, get the packet tracer file. Just click on the following link
To watch the video on youtube
To download the video from mediafire
To get automatic updates, join a facebook group (netsyshorizon)
https://www.facebook.com/groups/954180217947066/

Related Links:
OSPF Cost Calculation and Configuring Bandwidth/ip ospf cost/reference bandwidth
https://youtu.be/zgqaVkQe5Sw
EIGRP Composite Metric Calculation and Configuring different delay values and Bandwidth values
https://youtu.be/GsnV4Bc3On8
Cisco router WAN Redundancy/WAN Failover and Change Routing dynamically Using IP SLA - Route Tracking
https://youtu.be/x3xZhbrX7Ww
Clock Rate vs Bandwidth - Configuring clock rate and bandwidth
https://youtu.be/rntsm5bHagI
Configure Default routes on cisco routers
https://youtu.be/E5-kpZt8LU4
Static Routing Configuration Using Packet Tracer
https://youtu.be/v05Jm4h-ZmsKeywords:static routing configuration in packet tracer ; static routing between 3 routers ; static routing cisco ; static routing configuration ; static routing between 2 routers ; static routing on packet tracer ; static routing cisco packet tracer ; static routing gns3 ; static routing configuration in gns3 ; static routing explained ; static routing tutorial ; static routing and dynamic routing ; static routing between 4 routers ; static routing basics ; static routing ccna ; static routing configuration in packet tracer in hindi ; static routing commands ; ccna static routing configuration ; configure ip static routing ; static and dynamic routing ; static vs dynamic routing ; static routing hindi ; static routing in urdu ; static routing in gns3 ; static routing in packet tracer ; static routing packet tracer ; static routing protocol ; cisco static routing packet tracer ; static ip routing packet tracer ; static routing using packet tracer ; static routing 4 routers ; static routing 3 routers ; static routing vs dynamic routing ; simple static routing ; static routing table ; static routing with cisco packet tracer ; what is static routing ; static routing meaning ; static routing definition ; define static routing  ; sh ip route ; ip route ip address ;  configure ip static routing ; static routing example ; static routing protocol ; static routing commands ; static routing metrics ; static routing cisco packet tracer.